Foglight Release Notes for SQL Server

This release of Foglight for SQL Database brings a range of updates and enhancements aimed at improving performance, reliability, and usability.

This section covers the following key areas:

What’s New

FeaturesGA Month
The SPI Global View now supports SQL Server PI agents.August 2026
Unified PI REST API to add support for SnowflakeMay 2026
Added ability to collect deadlocks in a dedicated extended event session for better efficiency. For more information refer to Deadlock Collection Methods.December 2025
Enhance the backup alarms for availability group databases. Alarm now checking backup across all availability group replicas monitored by Foglight.December 2025
Enhanced Quick View and Real-time view for managed instanceDecember 2025
Added an alarm for memory utilization for managed instanceDecember 2025
Enhanced support for Azure SQL Managed instance - new resource utilization alarms and an updated overview displaying managed instance resource usage.September 2025
Enhanced support for Availability Groups - new alarms to track RPO and RTO based on threshold as well as new chartsSeptember 2025
Introduce Query Explorer - Introduce an easy and quick way to find queries and tune them by their text. Just copy your query from any tool and quickly get all query insights in one view. Also support analysis of top queries by their resource consumption. For more information, refer to Viewing Query Explorer.July 2025
Collecting deadlocks via extended events for AWS RDSJuly 2025
Support MFA connection using “Microsoft Entra” for Azure DB/MI.February 2025

Resolved Issues


Issue IDDescriptionTime Fixed
FOG-12702Deadlock collection dedicated session not created for AWS RDS instancesOctober 2026
FOG-11774Graphs occasionally appear to be polygonsAugust 2026
FOG-14361DBSS Cluster Failover Alarm Fires for Servers Not Part of a Failover ClusterJuly 2026
FOG-14268User level access dashboard doesn’t show any instances if any BI instances are monitoredJuly 2026
FOG-13966Dedicated XE session not created for on-prem SQL Server 15.0.2000.5 (script-version mapping missing)June 2026
FOG-13770java.lang.NoSuchFieldException: sys_paths when using MSSQL Windows Custom Auth (NTLMv2) on Java 17June 2026
FOG-13502Backup Location SQL Query Returns Invalid Path for Malformed Device NamesJune 2026
FOG-13512DataDirect JDBC vulnerabilityJune 2026
FOG-13305DBSSRMIDatabaseIndexList fails on large databases due to numeric overflow in index size/row calculationsJune 2026
FOG-13149SQL Server backup alarms are wrongfully fired when old backup exist on a secondary replicaMarch 2026
FOG-12720Advisories/graphs not loading for certain events like lock waitsMarch 2026
FOG-12525No blocking data when selecting a range of more than 30 daysMarch 2026
FOG-12455Missing scrollbar in top FglAMs panel in the SQL PI Administration pageMarch 2026
FOG-12449DBSS_Jobs_Failed alarm doesn’t trigger on the first timeMarch 2026
HFIX-606No alarm for 1st job failureJanuary 2026
FOG-11780Rule Template for “DBSS - Buffer Pages Free” is Enabled Despite Registry Value Disabling AlarmDecember 2025
FOG-3466Top Disk Space Usage Report includes RDS instancesDecember 2025
FOG-5887Legacy LOB Type Incompatibility with _SC and _UTF8 Collations in Blocking_List and DBSS_Top1000_dm_Exec_Query_Stats_Entries collectionsSeptember 2025
FOG-11952DBSS Long Running Session Threshold not getting updated via Alarm TemplateSeptember 2025
FOG-11225DBSS_HADR_Availability_Group_Databases_11_0_0_0 collection failing in SQL server 2012September 2025
FOG-12012Graphs occasionally appear to be polygonsSeptember 2025
FOG-11468Cross Availability Report has Inconsistent UP/Start time valuesJuly 2025
FOG-11049Fix collection when SQL Server is running on a Linux machineJuly 2025
FOG-10962Incorrect sort by UpSince on SQL PI Global view dashboardJuly 2025
FOG-11283DBSS_JobsFailed-AutoClear get resetJuly 2025
FOG-11150SQL server show incorrect host name in Databases pageJuly 2025
FOG-10232DBSS_Error_Log_Data collection failing when monitored instances have DBs with different collationMarch 2025
FOG-10558DBSS_Agent_Job_List collection return incorrect job current_statusMarch 2025
FOG-10034fix the “IO Dimension” PI’s collection failed - table snot existFebruary 2025
FOG-4335Fix threshold setting for DBSS Long Running Job alarmFebruary 2025
FOG-9904Align current wait mapping to new versions wait eventsFebruary 2025
FOG-5463Fix blocking view to show recent blocking events even on large timeframesFebruary 2025
FOG-10121Support proxy for monitoring with PIFebruary 2025
FOG-4335DBSS Long Running Job: Rule would only work with Warning thresholdJanuary 2025
FOG-3795Create IC agent with FQDN host nameJanuary 2025
FOG-9893Changing credentials for DB agents doesn’t update credentials for PIDecember 2024
FOG-9787Use FQDN for Physical hostnameDecember 2024
FOG-9760SSRS agent doesn’t display dataNovember 2024
FOG-9684Add support for blocking in MARS (Multiple active results sets) sessionsNovember 2024
FOG-9140Blocking collections not returning sql_text when Multiple Active Result Sets (MARS) is enabled and blocking session not running active requestNovember 2024
FOG-9139Blocking collections not returning sql_text when Multiple Active Result Sets (MARS) is enabled and blocking session not running active requestNovember 2024